Highlighted
Scholar

Copy Product Function Not Working Correctly

When I use the "copy product" button the editor does nothing but show a box that says "copying product", but if I hit cancel the copied product will sometimes show up at the top of my products page. Has anyone else experienced any issues with "copy product" or is it just me?

16 REPLIES
Community Manager

Re: Copy Product Function Not Working Correctly

Are you seeing that with specific products, @111sportbike? If so, does the product have a lot of product options?

- Adam
Senior Community Specialist
Scholar

Re: Copy Product Function Not Working Correctly

I have had the same issue with a couple different products, both with 5 or 6 color options. It did not do the same thing on a product with zero options. Thank you for responding.

Community Manager

Re: Copy Product Function Not Working Correctly

Ok, thanks for the details. I tried replicated this with a test product of my own but couldn't. Can you try logging out, clearing your browser cache, then logging back in? I want to make sure it's not a cause of older back-end scripting being cached.

- Adam
Senior Community Specialist
Scholar

Re: Copy Product Function Not Working Correctly

I'm having the same issue with a product that only has two options and two images. Copy procedure in endless loop and you need to cancel to leave the dialogue. Tried re-starting and clearing cache. 

Employee Moderator

Re: Copy Product Function Not Working Correctly

Is there a specific product you're seeing this on? We'll see what we can do to reproduce it here.

Re: Copy Product Function Not Working Correctly

I'm having the exact same issues. How can I resolve the copy function not working correctly?

Employee Moderator

Re: Copy Product Function Not Working Correctly

Hello PrimePerformanc! Just to clarify, is there a particular product you're having fail to cancel when copying?

Explorer

Re: Copy Product Function Not Working Correctly

Same problem here. I've tried to Copy Product with all the stuff in my store and it worked a couple times but now it just hangs up, spinning, and spinning, and spinning...

 

There's definitely a bug. Please fix. We pay for this service.

Community Manager

Re: Copy Product Function Not Working Correctly

Are you making a copy of a product that's a copy of another product (which was in turn a copy of another product), or are you trying to copy a product that was made new itself?

- Adam
Senior Community Specialist